Cisco UCS

Cisco Unified Communications 500 Series for Small Business (UC500)

Cisco UC LAB Network Diagram

The Cisco UC Series platforms can either be configured through the “Cisco Configuration Assistant” or via the IOS CLI. We have provided both examples below. The CCA is much easier to navigate for telephone configuration than feeling your way through the CLI. The configuration lines at the end of this page are the outputs from the CCA’s generated config.

Configuring the UC though the Cisco Configuration Assistant

Below is the SIP Trunking configuration screen for the UC. In this example we are using a SIP trunking service from an ITSP (Internet Telephony Service Provider) RBS (Rogers Business Solutions). RBS recommends using DNS SRV based dialing wherever possible. RBS had provided us with the DNS name of “sbc.myrbs.ca” to send and receive calls from (this was entered into the Proxy Server field). RBS also provided us with their DNS servers to simplify our configuration. These IPs were “173.46.30.4″ and “173.46.30.36″ (entered into DNS Server Address).

The Advanced Options screen provides some timer settings, which we have left mostly default. The only time we would expect to change any of these timers is when extremely long call duration is expected (such as a call duration of more than 12 hours). In some cases depending on the distance (latency) to the RBS SBCs the Invite Retries and Connection Timer should be at least doubled (to 4-5 retries & 400-500ms connect).

The Service Provider Settings tab provides some fine tuning of the SIP negotiation settings  between the UC and ITSP. In this case we have given the ITSP a friendly name “ROGSIP” (to keep things short). We only ever want to use G711ulaw as our Preferred Audio Codec  to eliminate the possibility of having a trans-coded audio stream. RBS recommends that we only ever use T.38 for faxing. Though they had mentioned G711 faxing is possible it not guaranteed, though T.38 faxing is guaranteed. RBS recommended using RFC2833 for DTMF with an RTP payload value of 101. These trunks are configured for direct IP-to-IP calling, therefore no registration is necessary.

The Session Data sub-screen adds some further session tweaks if necessary.

Some important Voice configuration lines

Below is a copy of the “sanitized” configuration output from the Cisco Configuration Assistant as shown above. Carrier specific details have been removed.

Voice Codec Class Configuration

!
voice class codec 1
 codec preference 1 g711ulaw
!

Incomming Dial-Peer

!
dial-peer voice 1000 voip
 permission term
 description ** Incoming call from SIP trunk (CARRIER) **
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!

Outgoing Dial-Peer

!
dial-peer voice 1022 voip
 corlist outgoing call-national
 description **CCA*North American-10-Digit*Long Distance**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 91[2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1023 voip
 corlist outgoing call-local
 description **CCA*North American-10-Digit*10-Digit Local**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 9[2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!

SIP User Agent

!
sip-ua 
 keepalive target dns:sip.carrier.domain.name
 retry invite 2
 retry register 10
 timers connect 100
 timers keepalive active 100
 sip-server dns:sip.carrier.domain.name
 host-registrar
!
Note!
Configuration “dns:sip.carrier.domain.name” is for DNS SRV-Based dialing
This can also be IP-Based using “ipv4:xxx.xxx.xxx.xxx”

 

Some basic network level configuration lines

Network Interfaces

!
interface FastEthernet0/0=
 description ROUTER OUTSIDE (WAN) FACING INTERFACE
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
!
interface Integrated-Service-Engine0/0
 description INTERFACE TO INTEGRATED CUE SERVER
 ip unnumbered Loopback0
 ip nat inside
 ip virtual-reassembly in
 service-module ip address 10.1.10.1 255.255.255.252
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
 description SWITCHPORT INSIDE
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/8
 description SWITCHPORT SIP TRUNKING
 switchport access vlan 101
!
interface Vlan1
 description ROUTER INSIDE (DATA) VLAN
 ip address 192.168.10.1 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan100
 description ROUTER INSIDE (VOICE) VLAN
 ip address 10.1.1.1 255.255.255.0
 ip access-group 103 in
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan101
 description ROUTER SIP TRUNKING (EXPANSION) FACING INTERFACE
 ip address 10.41.255.10 255.255.255.248
 ip nat inside
 ip virtual-reassembly in
!

Leave a Reply

Your email address will not be published. Required fields are marked *

*

HTML tags are not allowed.